Client Mode

Device: NANO
Type: Bug
Status: Closed

I have had issues connecting to APs via wlan1 in client mode. The issue is this specifically: when I boot up the pineapple and connect to its UI, frequently when I go to Networking, select wlan1 and scan, the available networks display as simply "false".

However, if I ignore this fact and simply click connect anyway, it will connect to a random open network. Eventually, the pineapple will come back around and identify networks when scanned. The interesting thing is that when in Recon mode, the pineapple easily identifies APs and clients, but I suspect this may be due to it using wlan0 in this function.

Comments:

Sebkinne
2016/01/01 18:29
Hi pbtomlinson,

This am I correct in assuming that this issue only happens when wlan1 is in monitor mode (wlan1mon)? If so, we should have corrected the issue and will ship it in the next firmware release.


Best Regards,
Sebkinne
Pbtomlinson
2016/01/05 18:43
Hi Sebkinne,

It happens when wlan1 is both in monitor and managed modes, unfortunately. Please let me know if you have any other questions regarding the behavior.

Best,
Bennett
Lobezno
2016/01/12 23:11
hi,

I haver resolve modify the file /etc/config/wireless and the last part I change, and add:

config wifi-iface
option device 'radio1'
option mode 'sta'
option network 'wan'
option said 'SSID'
option encryption 'psk2+ccmp'
option key '********'
Pbtomlinson
2016/01/19 15:18
Hi Sebkinne,

Just an update. The client scanning and connectivity is working much better. However, I am still encountering issues on occasion where I scan with wlan1 (while PineAP is disabled) as well as when scanning with wlan2 when an alfa card is inserted into the USB slot where the Access Point field comes up with 'false' in the drop down.

Just wanted to keep you up to date on this behavior.

Best,
pbtomlinson
Sebkinne
2016/01/23 00:09
This issue should now be resolved in firmware version 1.0.5 and the Network module update from the Module Manager.

Best Regards,
Sebkinne

Add Comment:

Please log in to comment.